This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined
by a TriangulatedShellComponent.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public class TriangulationInterfaceForTriangulatedShellComponent : TriangulationInterface |
Visual Basic |
---|
Public Class TriangulationInterfaceForTriangulatedShellComponent _ Inherits TriangulationInterface |
Visual C++ |
---|
public ref class TriangulationInterfaceForTriangulatedShellComponent : public TriangulationInterface |
Remarks
Compare to TriangulationInterfaceForTriangulatedSolidOrShell, which treats with the entire solid or shell as
a single triangulated structure.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedShellComponent
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedShellComponent