Retrieves or set the miter locked status at the end.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
bool this[ int index ] { get; set; } |
Visual Basic |
---|
Property IsMiterLocked ( _ index As Integer _ ) As Boolean Get Set |
Visual C++ |
---|
property bool IsMiterLocked[int index] { bool get (int index); void set (int index, bool value); } |
Parameters
- index
- Type: System..::..Int32
Remarks
Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown.
For beams, only if the beam is extended and is mitered with other beams at the end,
it can be locked. Otherwise, the setting is invalid