Sets the graphic overrides assigned to elements in a particular user workset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetGraphicOverrides( WorksetId worksetId, WorksharingDisplayGraphicSettings overrides ) |
Visual Basic |
---|
Public Sub SetGraphicOverrides ( _ worksetId As WorksetId, _ overrides As WorksharingDisplayGraphicSettings _ ) |
Visual C++ |
---|
public: void SetGraphicOverrides( WorksetId^ worksetId, WorksharingDisplayGraphicSettings^ overrides ) |
Parameters
- worksetId
- Type: Autodesk.Revit.DB..::..WorksetId
The workset of interest, which must be a user workset.
- overrides
- Type: Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings
The desired graphic overrides for this workset.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |