Controls the default visibility of the pane upon the first time
the pane/plugin is loaded into Revit.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public bool VisibleByDefault { get; set; } |
Visual Basic |
---|
Public Property VisibleByDefault As Boolean Get Set |
Visual C++ |
---|
public: property bool VisibleByDefault { bool get (); void set (bool value); } |
Remarks
By default, panes will be created and shown in the Revit UI when
Revit is launched for the first time. Subsequent loads of the Revit
UI will determine the visibility of the panes based upon there state
at the close of the previous Revit session. Providers can set this
to false if they wish there panes to NOT be shown by default.