Sets the Alignment Method to the supplied Analytical Alignment Method
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void SetAnalyticalAlignmentMethod( AnalyticalAlignmentMethod alignmentMethod ) |
Visual Basic |
---|
Public Sub SetAnalyticalAlignmentMethod ( _ alignmentMethod As AnalyticalAlignmentMethod _ ) |
Visual C++ |
---|
public: void SetAnalyticalAlignmentMethod( AnalyticalAlignmentMethod alignmentMethod ) |
Parameters
- alignmentMethod
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
Analytical Alignment Method which the Analytical Model should use for alignment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | alignmentMethod is not valid for this Sketch component. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |