Creates a new FormattedText object with unformatted text.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public FormattedText( string plainText ) |
Visual Basic |
---|
Public Sub New ( _ plainText As String _ ) |
Visual C++ |
---|
public: FormattedText( String^ plainText ) |
Parameters
- plainText
- Type: System..::..String
The text in a plain text form.
Remarks
The given text should have no more than 30,000 characters.
Line feed characters ('/n') are not allowed.
An empty string is allowed.
Examples

public void ReformatText(TextNote textNote, string textToChange) { String plainText = textNote.Text; FormattedText formattedText = new FormattedText(plainText); TextRange foundRange = formattedText.Find(textToChange, 0, false, true); while (foundRange.Length > 0) { formattedText.SetBoldStatus(foundRange, true); foundRange = formattedText.Find(textToChange, foundRange.End, false, true); } textNote.SetFormattedText(formattedText); }

Public Sub ReformatText(textNote As TextNote, textToChange As String) Dim plainText As [String] = textNote.Text Dim formattedText As New FormattedText(plainText) Dim foundRange As TextRange = formattedText.Find(textToChange, 0, False, True) While foundRange.Length > 0 formattedText.SetBoldStatus(foundRange, True) foundRange = formattedText.Find(textToChange, foundRange.[End], False, True) End While textNote.SetFormattedText(formattedText) End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |