The reason for calculation failure. If the calculation fails, this message will be shown in an error, or warning if we are editing the constraints.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public string ErrorMessage { get; set; } |
Visual Basic |
---|
Public Property ErrorMessage As String Get Set |
Visual C++ |
---|
public: property String^ ErrorMessage { String^ get (); void set (String^ value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: errorMessage is an empty string. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |