Removes an existing routing preference rule.
Thrown if the index is out of bounds.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void RemoveRule( RoutingPreferenceRuleGroupType groupType, int index ) |
Visual Basic |
---|
Public Sub RemoveRule ( _ groupType As RoutingPreferenceRuleGroupType, _ index As Integer _ ) |
Visual C++ |
---|
public: void RemoveRule( RoutingPreferenceRuleGroupType groupType, int index ) |
Parameters
- groupType
- Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be removed.
- index
- Type: System..::..Int32
The index position of removed routing preference rule in the group.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or- |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |