Sets the FormatOptions to optionally override the default settings in the Units class.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetFormatOptions( FormatOptions formatOptions ) |
Visual Basic |
---|
Public Sub SetFormatOptions ( _ formatOptions As FormatOptions _ ) |
Visual C++ |
---|
public: void SetFormatOptions( FormatOptions^ formatOptions ) |
Parameters
- formatOptions
- Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.
Remarks
See the UnitType property to determine the unit type of this field.
Examples

// format length units to display in feet and inches format public void FormatLengthFields(ViewSchedule schedule) { int nFields = schedule.Definition.GetFieldCount(); for (int n = 0; n < nFields; n++) { ScheduleField field = schedule.Definition.GetField(n); if (field.GetSpecTypeId() == SpecTypeId.Length) { FormatOptions formatOpts = new FormatOptions(); formatOpts.UseDefault = false; formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches); field.SetFormatOptions(formatOpts); } } }

' format length units to display in feet and inches format Public Sub FormatLengthFields(schedule As ViewSchedule) Dim nFields As Integer = schedule.Definition.GetFieldCount() For n As Integer = 0 To nFields - 1 Dim field As ScheduleField = schedule.Definition.GetField(n) If field.GetSpecTypeId().Equals(SpecTypeId.Length) Then Dim formatOpts As New FormatOptions() formatOpts.UseDefault = False formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches) field.SetFormatOptions(formatOpts) End If Next End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this ScheduleField, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |