Create a cylindrical helix.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static CylindricalHelix Create(
XYZ basePoint,
double radius,
XYZ xVector,
XYZ zVector,
double pitch,
double startAngle,
double endAngle
) |
Visual Basic |
---|
Public Shared Function Create ( _
basePoint As XYZ, _
radius As Double, _
xVector As XYZ, _
zVector As XYZ, _
pitch As Double, _
startAngle As Double, _
endAngle As Double _
) As CylindricalHelix |
Visual C++ |
---|
public:
static CylindricalHelix^ Create(
XYZ^ basePoint,
double radius,
XYZ^ xVector,
XYZ^ zVector,
double pitch,
double startAngle,
double endAngle
) |
Parameters
- basePoint
- Type: Autodesk.Revit.DB..::..XYZ
Base point of the axis. It can be any point in 3d.
- radius
- Type: System..::..Double
Radius. It should be a positive number.
- xVector
- Type: Autodesk.Revit.DB..::..XYZ
X vector. Should be Non-zero vector.
- zVector
- Type: Autodesk.Revit.DB..::..XYZ
Z vector = axis direction. Should be non-zero and orthogonal to X Vector.
- pitch
- Type: System..::..Double
Pitch. It should be non-zero number, can be positive or negative.
Positive means right handed and negative means left handed.
- startAngle
- Type: System..::..Double
Start angle. It specifies the start point of the Helix.
- endAngle
- Type: System..::..Double
End angle. It specifies the end point of the Helix.
End angle should not be equal to start angle.
Exceptions
See Also