Sets value of Analyze As parameter for this Element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void SetAnalyzeAs( AnalyzeAs analyzeAs ) |
Visual Basic |
---|
Public Sub SetAnalyzeAs ( _ analyzeAs As AnalyzeAs _ ) |
Visual C++ |
---|
public: void SetAnalyzeAs( AnalyzeAs analyzeAs ) |
Parameters
- analyzeAs
- Type: Autodesk.Revit.DB.Structure..::..AnalyzeAs
Indicates how Analytical Model is analyzed .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | analyzeAs is invalid for analytical model. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |