Tests whether the buffer is valid for rendering.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public bool IsValid() |
Visual Basic |
---|
Public Function IsValid As Boolean |
Visual C++ |
---|
public: bool IsValid() |
Return Value
True if the buffer is valid for rendering, false otherwise.
Remarks
The buffers are internally associated with low-level graphics state and may become invalidated when
the state changes. Therefore, an application should test each buffer for validity before submitting its
contents for rendering. If the buffer becomes invalid, the application should re-create its contents and
write them to a new buffer.