Multiplies this vector by the specified value and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public XYZ Multiply( double value ) |
Visual Basic |
---|
Public Function Multiply ( _ value As Double _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ Multiply( double value ) |
Parameters
- value
- Type: System..::..Double
The value to multiply with this vector.
Return Value
The multiplied vector.
Remarks
The multiplied vector is obtained by multiplying each coordinate of
this vector by the specified value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number. |