Returns a reference to a given curve within the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public Reference GetReference(
	AnalyticalModelSelector selector
)
Visual Basic
Public Function GetReference ( _
	selector As AnalyticalModelSelector _
) As Reference
Visual C++
public:
Reference^ GetReference(
	AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalModelSelector
Specifies where in the analytical model the reference lies.

Return Value

Requested reference.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException selector is not valid for this AnalyticalModel.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also