Defines bar diameter of rebar
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double BarDiameter { get; set; } |
Visual Basic |
---|
Public Property BarDiameter As Double Get Set |
Visual C++ |
---|
public: property double BarDiameter { double get (); void set (double value); } |
Field Value
The bar diameter of rebar
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the bar diameter barDiam is not positive or bigger than the smallest value of 1.0, and current internal values of standard bend diameter, standard hook bend diameter and stirrup/tie bend diameter |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |