The family parameter label of the BaseArray.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyParameter Label { get; set; } |
Visual Basic |
---|
Public Property Label As FamilyParameter Get Set |
Visual C++ |
---|
public: property FamilyParameter^ Label { FamilyParameter^ get (); void set (FamilyParameter^ value); } |
Remarks
The label associates the number of members of the array with a family parameter.
A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter.
To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the family parameter's ParameterType is not ParameterType.Integer. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to label the BaseArray out of family document. |