Applies an ExclusionFilter to the collector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public FilteredElementCollector Excluding( ICollection<ElementId> idsToExclude ) |
Visual Basic |
---|
Public Function Excluding ( _ idsToExclude As ICollection(Of ElementId) _ ) As FilteredElementCollector |
Visual C++ |
---|
public: FilteredElementCollector^ Excluding( ICollection<ElementId^>^ idsToExclude ) |
Parameters
- idsToExclude
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The ids to exclude from the results.
Return Value
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Remarks
Elements passed to this filter will be automatically excluded from the results.
If you have an active iterator to this collector it will be stopped by this call.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |