Get the duct settings of the project.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static DuctSettings GetDuctSettings( Document document ) |
Visual Basic |
---|
Public Shared Function GetDuctSettings ( _ document As Document _ ) As DuctSettings |
Visual C++ |
---|
public: static DuctSettings^ GetDuctSettings( Document^ document ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
Return Value
The duct settings of the project.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |