Returns the filterable parameters common to the given categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static ICollection<ElementId> GetFilterableParametersInCommon( Document aDoc, ICollection<ElementId> categories ) |
Visual Basic |
---|
Public Shared Function GetFilterableParametersInCommon ( _ aDoc As Document, _ categories As ICollection(Of ElementId) _ ) As ICollection(Of ElementId) |
Visual C++ |
---|
public: static ICollection<ElementId^>^ GetFilterableParametersInCommon( Document^ aDoc, ICollection<ElementId^>^ categories ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document containing the categories and parameters to query.
- categories
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories for which to determine the common parameters.
Return Value
The set of filterable parameters common to the given categories.
Remarks
A filterable category in Revit has a set of filterable parameters. The filterable parameters common to a set of categories is the intersection of all these filterable parameter sets.
This set defines the set of parameters that may be used to define a rule on a ParameterFilterElement with a certain set of categories.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |