Constructs a filter to match elements which intersect the given element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public ElementIntersectsElementFilter( Element element ) |
Visual Basic |
---|
Public Sub New ( _ element As Element _ ) |
Visual C++ |
---|
public: ElementIntersectsElementFilter( Element^ element ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The element to check for intersection.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |