Calculates the alignment status of each face of the solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public IDictionary<Face, ExtrusionAnalyzerFaceAlignment> CalculateFaceAlignment() |
Visual Basic |
---|
Public Function CalculateFaceAlignment As IDictionary(Of Face, ExtrusionAnalyzerFaceAlignment) |
Visual C++ |
---|
public: IDictionary<Face^, ExtrusionAnalyzerFaceAlignment>^ CalculateFaceAlignment() |
Return Value
Maps each face of the solid to its alignment status.
Remarks
You can obtain the element which produced the non-aligned face by passing
the face to Element.GetGeneratingElementIds().