Returns the maximum width the text element can be created with.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static double GetMaximumAllowedWidth( Document cdda, ElementId typeId ) |
Visual Basic |
---|
Public Shared Function GetMaximumAllowedWidth ( _ cdda As Document, _ typeId As ElementId _ ) As Double |
Visual C++ |
---|
public: static double GetMaximumAllowedWidth( Document^ cdda, ElementId^ typeId ) |
Parameters
- cdda
- Type: Autodesk.Revit.DB..::..Document
A document containing the new text element's type
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the text type
Return Value
The maximum allowed width in paper space [ft].
Remarks
Note that it is not necessarily a constant; it can be affected
by properties of the text type, such as the width factor.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |