The type of the top rail in the railing system.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public ElementId TopRailType { get; set; }
Visual Basic
Public Property TopRailType As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ TopRailType {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException When setting this property: The topRailType is not a valid top rail type.
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL

See Also