Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static void SplitFacesOfCuttingSolid( Element first, Element second, bool split ) |
Visual Basic |
---|
Public Shared Sub SplitFacesOfCuttingSolid ( _ first As Element, _ second As Element, _ split As Boolean _ ) |
Visual C++ |
---|
public: static void SplitFacesOfCuttingSolid( Element^ first, Element^ second, bool split ) |
Parameters
- first
- Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid
- second
- Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid
- split
- Type: System..::..Boolean
True to split the faces of intersection, false to unsplit them.
Remarks
There must be a cut between the input elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | There is no solid-solid cut between the input elements. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to split or unsplit faces of cutting solid |