The ID of the grouped schedule field used to calculate percentage totals.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ScheduleFieldId PercentageBy { get; set; } |
Visual Basic |
---|
Public Property PercentageBy As ScheduleFieldId Get Set |
Visual C++ |
---|
public: property ScheduleFieldId^ PercentageBy { ScheduleFieldId^ get (); void set (ScheduleFieldId^ value); } |
Field Value
InvalidElementId or the ID of the grouped field.
Remarks
A Percentage field calculates what percent of the total of another field
each element represents. If PercentageBy is InvalidScheduleFieldId,
the total is of all elements in the schedule. If PercentageBy is the
ID of one of the fields that the schedule is grouped by, the total is
of all elements in that group.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: percentageBy is not InvalidScheduleFieldId or the ID of a field that the schedule is grouped by. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField is not a percentage field. |