Enable or disable correcting lines that are slight off-axis.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool AutocorrectOffAxisLines { get; set; } |
Visual Basic |
---|
Public Property AutocorrectOffAxisLines As Boolean Get Set |
Visual C++ |
---|
public: property bool AutocorrectOffAxisLines { bool get (); void set (bool value); } |
Remarks
Enabling correcting lines that are slightly off-axis will snap lines that are close to axes
to the nearest axis. This will reduce warnings in Revit, but may cause elements that are created
from sketches to slightly change shape, and extrusions to slightly change directions.
Disabling this option will leave the original geometry intact but may cause warnings in Revit.
Default is true for Open IFC; it is ignored (and false) for Link IFC.