The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ElementId DeckProfileId { get; set; } |
Visual Basic |
---|
Public Property DeckProfileId As ElementId Get Set |
Visual C++ |
---|
public: property ElementId^ DeckProfileId { ElementId^ get (); void set (ElementId^ value); } |
Field Value
The default is InvalidElementId.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |