A method called when the shared family was found in the target document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
bool OnSharedFamilyFound( Family sharedFamily, bool familyInUse, out FamilySource source, out bool overwriteParameterValues ) |
Visual Basic |
---|
Function OnSharedFamilyFound ( _ sharedFamily As Family, _ familyInUse As Boolean, _ <OutAttribute> ByRef source As FamilySource, _ <OutAttribute> ByRef overwriteParameterValues As Boolean _ ) As Boolean |
Visual C++ |
---|
bool OnSharedFamilyFound( Family^ sharedFamily, bool familyInUse, [OutAttribute] FamilySource% source, [OutAttribute] bool% overwriteParameterValues ) |
Parameters
- sharedFamily
- Type: Autodesk.Revit.DB..::..Family
The shared family in the current family document.
- familyInUse
- Type: System..::..Boolean
Indicates if one or more instances of the family is placed in the project.
- source
- Type: Autodesk.Revit.DB..::..FamilySource%
This indicates if the family will load from the project or the current family.
- overwriteParameterValues
- Type: System..::..Boolean%
This indicates whether or not to overwrite the parameter values of existing types.
Return Value
Return true to continue loading the family, false to cancel.
Remarks
Triggered only when the family is both loaded and changed.