Retrieves a list of the parameters associated with all rules in the filter
that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public ISet<ElementId> GetElementFilterParametersForCategory( ElementId categoryId ) |
Visual Basic |
---|
Public Function GetElementFilterParametersForCategory ( _ categoryId As ElementId _ ) As ISet(Of ElementId) |
Visual C++ |
---|
public: ISet<ElementId^>^ GetElementFilterParametersForCategory( ElementId^ categoryId ) |
Parameters
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
The category for which parameters should be found.
Return Value
A set of parameter identifiers.
Remarks
Note that in the case when InvalidElementId specified as input %categoryId% this function returns
parameters common to all categories used by this ParameterFilterElement,
i.e. it is equivalent to ParameterFilterElement.GetElementFilterParameters().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |