A base class for an application-specific logger. It should be used to track errors during conversion and/or , track conversion progress, cancel a conversion process if necessary.
Implementing a logger class is optional, but highly recommended for all but most basic data converters.
The base class is UI- and language-independent. It is up to the using app to implement UI. Language-specifc data may be used to communicate information to application users.
English should be used to communicate data of interest to Revit development.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public interface IDataConversionMonitor |
Visual Basic |
---|
Public Interface IDataConversionMonitor |
Visual C++ |
---|
public interface class IDataConversionMonitor |