Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Function NewFormByCap ( _
isSolid As Boolean, _
profile As ReferenceArray _
) As Form |
Parameters
- isSolid
- Type: System..::..Boolean
Indicates if the Form is Solid or Void.
- profile
- Type: Autodesk.Revit.DB..::..ReferenceArray
The profile of the newly created cap. It should consist of only one curve loop.
Return Value
If creation was successful new form is returned.
See Also