Gets the individual stairs or stairs group on the given base level.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public Stairs GetStairsOnLevel( ElementId levelId ) |
Visual Basic |
---|
Public Function GetStairsOnLevel ( _ levelId As ElementId _ ) As Stairs |
Visual C++ |
---|
public: Stairs^ GetStairsOnLevel( ElementId^ levelId ) |
Parameters
- levelId
- Type: Autodesk.Revit.DB..::..ElementId
The base level id.
Return Value
The id of stairs element on the given level.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |