Add a curve to the shape representation stored in this WireframeBuilder.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void AddCurve( Curve GCurve ) |
Visual Basic |
---|
Public Sub AddCurve ( _ GCurve As Curve _ ) |
Visual C++ |
---|
public: void AddCurve( Curve^ GCurve ) |
Parameters
- GCurve
- Type: Autodesk.Revit.DB..::..Curve
The curve to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | GCurve is not acceptable for a wireframe shape representation. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |