A constraint which can be applied to a RebarShapeSegment, and causes the segment
to be replaced with a 180-degree arc. The arc's radius is not specified
by the shape; instead it is a "default bend radius," taken from
the RebarBarType associated with the Rebar instance.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public class RebarShapeConstraint180DegreeDefaultBend : RebarShapeConstraint |
Visual Basic |
---|
Public Class RebarShapeConstraint180DegreeDefaultBend _ Inherits RebarShapeConstraint |
Visual C++ |
---|
public ref class RebarShapeConstraint180DegreeDefaultBend : public RebarShapeConstraint |
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeDefaultBend
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeDefaultBend