Whether the visibility can be controlled by the user for this category in this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool this[ View view ] { get; } |
Visual Basic |
---|
Public ReadOnly Property AllowsVisibilityControl ( _ view As View _ ) As Boolean Get |
Visual C++ |
---|
public: property bool AllowsVisibilityControl[View^ view] { bool get (View^ view); } |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view where visibility control might be allowed.
Remarks
There are some categories in Revit that are hidden to users in the Object Styles and
Visibility dialog. Their visibility cannot be controlled for a particular view. This property
identifies if the category allows visibility control (and thus allows the Visible property to
be set).