The target percentage of the reference roof surface that is to
be covered with automatically generated skylights. Revit will use this number when
determining the size, shape, and location of automatically generated skylights.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public double PercentageSkylights { get; set; } |
Visual Basic |
---|
Public Property PercentageSkylights As Double Get Set |
Visual C++ |
---|
public: property double PercentageSkylights { double get (); void set (double value); } |
Remarks
The resulting coverage of the roof with skylights is not guaranteed to
match this value. It is a target.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The percentage skylights value is between 0.00 and 0.95. |