Identifies if the naming category is valid for an assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public static bool IsValidNamingCategory(
	Document document,
	ElementId namingCategoryId,
	ICollection<ElementId> assemblyMemberIds
)
Visual Basic
Public Shared Function IsValidNamingCategory ( _
	document As Document, _
	namingCategoryId As ElementId, _
	assemblyMemberIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool IsValidNamingCategory(
	Document^ document, 
	ElementId^ namingCategoryId, 
	ICollection<ElementId^>^ assemblyMemberIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the assembly instance.
namingCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The id of the naming category for the assembly instance.
assemblyMemberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Member ids to check validity of naming category

Return Value

True if the naming category is valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also