Creates a new RoutingCondition.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public RoutingCondition( double diameter ) |
Visual Basic |
---|
Public Sub New ( _ diameter As Double _ ) |
Visual C++ |
---|
public: RoutingCondition( double diameter ) |
Parameters
- diameter
- Type: System..::..Double
The diameter of a routing segment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for diameter must be greater than 0 and no more than 30000 feet. |