Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public bool IsFlippedOnFace( int index ) |
Visual Basic |
---|
Public Function IsFlippedOnFace ( _ index As Integer _ ) As Boolean |
Visual C++ |
---|
public: bool IsFlippedOnFace( int index ) |
Parameters
- index
- Type: System..::..Int32
The index of the face (0 or 1).
Return Value
true if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.
Remarks
Outer edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation,
and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction
in which the edge's loop is being traversed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1. |