Indicates if digit grouping symbols should be displayed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool UseDigitGrouping { get; set; } |
Visual Basic |
---|
Public Property UseDigitGrouping As Boolean Get Set |
Visual C++ |
---|
public: property bool UseDigitGrouping { bool get (); void set (bool value); } |
Field Value
True if digit grouping symbols should be displayed, false otherwise. The default is false.
Remarks
When UseDigitGrouping is true, digit grouping symbols (i.e.
thousands separators) will be displayed when needed. For example,
123456789.00 may be displayed as 123,456,789.00. The precise
display is determined by the DigitGroupingSymbol and
DigitGroupingAmount properties of the Units class.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions. |