The curve on which the hosted sweep segment is created.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Curve this[ Reference targetRef ] { get; } |
Visual Basic |
---|
Public ReadOnly Property ReferenceCurve ( _ targetRef As Reference _ ) As Curve Get |
Visual C++ |
---|
public: property Curve^ ReferenceCurve[Reference^ targetRef] { Curve^ get (Reference^ targetRef); } |
Parameters
- targetRef
- Type: Autodesk.Revit.DB..::..Reference
Reference of the curve that hosts the object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails. |