Sets the shear modulus of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetShearModulus( double shearModulus ) |
Visual Basic |
---|
Public Sub SetShearModulus ( _ shearModulus As Double _ ) |
Visual C++ |
---|
public: void SetShearModulus( double shearModulus ) |
Parameters
- shearModulus
- Type: System..::..Double
Remarks
The shear modulus is one-dimensional for wood-based and isotropic materials.
This method sets the x, y, and z components to the same value.
The value is in Newtons per foot meter (N/(ft · m)).