Insert a waypoint at the specified index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2020.2

Syntax

C#
public void InsertWaypoint(
	XYZ waypoint,
	int index
)
Visual Basic
Public Sub InsertWaypoint ( _
	waypoint As XYZ, _
	index As Integer _
)
Visual C++
public:
void InsertWaypoint(
	XYZ^ waypoint, 
	int index
)

Parameters

waypoint
Type: Autodesk.Revit.DB..::..XYZ
The waypoint to insert.
index
Type: System..::..Int32
The index to insert the waypoint at.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException Index is invalid for an existing or new waypoint for this path. -or- This functionality is not available in Revit LT. -or- Cannot perform this operation for a path of travel in a group.

See Also