Gets the distance from the RebarConstrainedHandle to the target Rebar handle surface.
The RebarConstraintType of the RebarConstraint must be 'ToOtherRebar.'
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
public double GetDistanceToTargetRebar() |
Visual Basic |
---|
Public Function GetDistanceToTargetRebar As Double |
Visual C++ |
---|
public: double GetDistanceToTargetRebar() |
Return Value
Returns the distance from the RebarConstrainedHandle to the target Rebar handle surface.
Remarks
Throws exception if the constraint is not to other rebar or if the target constraint is to bar bend or hook bend.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. |