Gets the curve segment generated by intersection.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public Curve GetCurveSegment( int index ) |
Visual Basic |
---|
Public Function GetCurveSegment ( _ index As Integer _ ) As Curve |
Visual C++ |
---|
public: Curve^ GetCurveSegment( int index ) |
Parameters
- index
- Type: System..::..Int32
The index.
Return Value
The curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range. |