Sets the unit used to quantify values.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public FormatOptions SetUnitTypeId( ForgeTypeId unitTypeId ) |
Visual Basic |
---|
Public Function SetUnitTypeId ( _ unitTypeId As ForgeTypeId _ ) As FormatOptions |
Visual C++ |
---|
public: FormatOptions^ SetUnitTypeId( ForgeTypeId^ unitTypeId ) |
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
The unit identifier.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions. |