Gets the origin and rotation of coordinate system that is used by translation and rotation parameters, like X Translation or Z Rotation.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public Transform GetDegreesOfFreedomCoordinateSystem() |
Visual Basic |
---|
Public Function GetDegreesOfFreedomCoordinateSystem As Transform |
Visual C++ |
---|
public: Transform^ GetDegreesOfFreedomCoordinateSystem() |