Retrieves the set of curves forming the boundary of the Area Reinforcement.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public IList<ElementId> GetBoundaryCurveIds() |
Visual Basic |
---|
Public Function GetBoundaryCurveIds As IList(Of ElementId) |
Visual C++ |
---|
public: IList<ElementId^>^ GetBoundaryCurveIds() |
Return Value
A collection of ElementIds of AreaReinforcementCurve elements.
Remarks
Each ElementId in the collection is an Id of an Element of type AreaReinforcementCurve. Each element has a Curve property
to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side,
hook type, and hook direction of each layer of bars terminating at the curve.