If the DimensionStyleType is LinearFixed, validates that the references are valid
for an aligned multi-reference annotation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static bool AreReferencesValidForLinearFixedDimension( Document document, ElementId ownerViewId, MultiReferenceAnnotationOptions options ) |
Visual Basic |
---|
Public Shared Function AreReferencesValidForLinearFixedDimension ( _ document As Document, _ ownerViewId As ElementId, _ options As MultiReferenceAnnotationOptions _ ) As Boolean |
Visual C++ |
---|
public: static bool AreReferencesValidForLinearFixedDimension( Document^ document, ElementId^ ownerViewId, MultiReferenceAnnotationOptions^ options ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document for the multi-reference annotation.
- ownerViewId
- Type: Autodesk.Revit.DB..::..ElementId
The view in which the multi-reference annotation will appear.
- options
- Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.
Return Value
True DimensionStyleType does not equal LinearFixed or if an aligned multi-reference annotation can be created from the references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |