Offsets a planar face of the free form element a certain distance in the normal direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public void SetFaceOffset(
Face face,
double offset
) |
Visual Basic |
---|
Public Sub SetFaceOffset ( _
face As Face, _
offset As Double _
) |
Visual C++ |
---|
public:
void SetFaceOffset(
Face^ face,
double offset
) |
Parameters
- face
- Type: Autodesk.Revit.DB..::..Face
The face to offset.
- offset
- Type: System..::..Double
The magnitude of the offset. A positive value offsets out of the input solid. A negative value offsets into the solid shape.
Exceptions
See Also